Logo QF-Test

Finding valuable answers
in the Mailing List Archive.

 

Free Trial  Download  Buy

Thomas Max, QF-Test training and support

Use the full-text search on our web site to find helpful tips on the mailing list.

Thomas Max, 
Sr. Software Engineer & Trainer, QFS

2017 up to now  | 2016 | 2015 | 2014 | 2013 | 2012 | 2011 | 2010 | 2009 | 2008 | 2007

(older archive entries before 2007 are not shown here, but included in the onsite-search)

Mailing List - Entries of 2015


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[QF-Test] WG: Running Maven Script in QF-Test > Failes Irregulary


  • Subject: [QF-Test] WG: Running Maven Script in QF-Test > Failes Irregulary
  • From: Eichner Lukas VIB-AZ311 <Eichner.Lukas@?.de>
  • Date: Thu, 13 Aug 2015 08:25:11 +0200

Hi Gregor,

thank you for your answer!

Actually the problem was in my test-script. Using too many variables (making the script unclear) I accidentally run a wrong (not-working) script.

Sorry that I took your time, without needing actually help.

Best Regards
Lukas

-----Ursprüngliche Nachricht-----
Von: Gregor Schmid [mailto:Gregor.Schmid@?.de]
Gesendet: Mittwoch, 12. August 2015 16:34
An: qftest-list@?.de
Cc: Eichner Lukas VIB-AZ311
Betreff: Re: [QF-Test] Running Maven Script in QF-Test > Failes Irregulary


Hi Lukas,

QF-Test should not interfere with maven but maybe maven doesn't like
QF-Test's agent.

Please try the following:

Insert a 'Server script' node with

rc.setOption(Options.OPT_PLAY_CONNECT_VIA_AGENT, false)
rc.setOption(Options.OPT_PLAY_IMPLICIT_INSTRUMENTATION, false)

before starting maven. After the respective 'Wait for process to
terminate' node, insert the following script:

rc.unsetOption(Options.OPT_PLAY_CONNECT_VIA_AGENT)
rc.unsetOption(Options.OPT_PLAY_IMPLICIT_INSTRUMENTATION)

Does that improve your success rate?

Otherwise we'll need to dig deeper. In that case please get in touch
directly with our support.

Best regards,
    Greg


Eichner Lukas VIB-AZ311 <Eichner.Lukas@?.de> writes:

> Hi QF-Test-Experts,
>
> in my GUI-Test it is necessary to run a maven script, which setups (or resets) a database.
>
> I run the Maven-Script like this:
>
> Start Process
> Client: BuildDB
> Executable: C:/Windows/System32/cmd.exe
> Directory: $(builddb.directory)
> Executable Parameters: /C "call mvn clean install"
>
> In ~50% this Script-Execution works, but in ~50% the build failes.
> If failed or not seems very random, mostly you just have to rerun the script (manually) and the
> build succeeds.
>
> If I run the Script in the actual cmd (same command: mvn clean install) it works in 100% of the
> times, so I guess it's a problem of QF-Test.
>
> Does anyone know a solution for my problem, or had similar problems?
> Or are there other (possibly better) ways to run a maven command?
>
> Thank you & best regards
>
> Lukas

--
Gregor Schmid

E: gregor.schmid@?.de
T: +49 8171 38648-11
F: +49 8171 38648-16

Quality First Software GmbH | www.qfs.de
Tulpenstr. 41 | 82538 Geretsried | Germany
GF Gregor Schmid, Dr. Martina Schmid, Karlheinz Kellerer
HRB München 140833



Videos Downloads Documentation Buy Free Trial