2018 bis heute | 2017 2016 2015 2014 | 2013 | 2012

Mailingliste - Einträge 2018 bis heute

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Exchange Server">
<!-- converted from rtf -->
<style><!-- .EmailQuote { margin-left: 1pt; padding-left: 4pt; border-left: #800000 2px solid; } --></style>
</head>
<body>
<font face="Arial, sans-serif" size="2">
<div>Hi QF-Test-Experts,</div>
<div> </div>
<div>in my GUI-Test it is necessary to run a maven script, which setups (or resets) a database.</div>
<div> </div>
<div>I run the Maven-Script like this:</div>
<div><font size="2"> </font></div>
<div>Start Process</div>
<div>Client: BuildDB</div>
<div>Executable: C:/Windows/System32/cmd.exe</div>
<div>Directory: $(builddb.directory)</div>
<div>Executable Parameters: /C<font size="2"> "</font>call mvn clean install"</div>
<div><font size="2"> </font></div>
<div>In ~50% this Script-Execution works, but in ~50% the build failes.</div>
<div>If failed or not seems very random, mostly you just have to rerun the script (manually) and the build succeeds.</div>
<div> </div>
<div>If I run the Script in the actual cmd (same command: mvn clean install) it works in 100% of the times, so I guess it’s a problem of QF-Test.</div>
<div> </div>
<div>Does anyone know a solution for my problem, or had similar problems?</div>
<div>Or are there other (possibly better) ways to run a maven command?</div>
<div> </div>
<div>Thank you & best regards</div>
<div><font size="2"> </font></div>
<div>Lukas</div>
<div><font size="2"> </font></div>
<div><font size="2"> </font></div>
</font>
</body>
</html>