2018 bis heute | 2017 2016 2015 2014 | 2013 | 2012

Mailingliste - EintrÀge 2018 bis heute

Hello,<br><br>If I'm right the Nasa World Wind library uses JOGL for rendering (A Java binding of OpenGL).<br><br>QFTest "default image check" uses Java2D rendering to record the image.<br><br>So it's "normal" that there is nothing in the "recorded" image. (As OPenGL is not Java2D based)<br>
And when replayed the test capture a Java2D image too.<br><br><br>We run into the same problem in our application for viewers with OpenGL rendering.<br>I suggest you to right your own ImageChecker, that's what we did and it works pretty well.<br>
<br>This Jython/Groovy script will add your "cutom check" into QFTest and when you will right click on your component to record a check.<br>The menu will have an extra item "my custom check"<br><br>We wrote our script with the help of Qfs support, so I guess they will be able to provide you more information/help.<br>
<br>But I can provide you a snippet/example of jython code which do that tomorrow. (European time here :))<br><br>Regards,<br><br><br><br clear="all"><pre cols="72"><span style="color: rgb(153, 153, 153);">---<br>Ivan Boelle</span><br style="color: rgb(153, 153, 153);">
<span style="color: rgb(153, 153, 153);"></span><span style="color: rgb(153, 153, 153);">INT, Interactive Network Technologies</span><br><br></pre><br><br><br>
<br><br><div class="gmail_quote">On Wed, Feb 9, 2011 at 8:17 PM, Nguyen, Minh <span dir="ltr"><<a href="mailto:minh.nguyen@viasat.com">minh.nguyen@viasat.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<div link="blue" vlink="purple" lang="EN-US"><div><p class="MsoNormal">Hi,</p><p class="MsoNormal"> </p><p class="MsoNormal">I am evaluating QF-Test 3.4M1 (4036) on Windows XP and am having trouble with the image check feature.</p>
<p class="MsoNormal"> </p><p class="MsoNormal">Our AUT is an Eclipse RCP application which utilizes the NASA World Wind library to display a map image.</p><p class="MsoNormal"> </p><p class="MsoNormal">When I use QF-Test to check the image, the image turns white when the mouse hovers over it (while recording the check). The screenshot captured in QF-Test for comparison is white as well. However, while executing the test, the image check passes even when it shouldn’t.</p>
<p class="MsoNormal"> </p><p class="MsoNormal">Any advice?</p><p class="MsoNormal"> </p><p class="MsoNormal">Thank you.</p><p class="MsoNormal"> </p><p class="MsoNormal"> </p></div></div><br>_______________________________________________<br>

qftest-list mailing list<br>
<a href="mailto:qftest-list@qfs.de">qftest-list@qfs.de</a><br>
<a href="http://www.qfs.de/mailman/listinfo/qftest-list" target="_blank">http://www.qfs.de/mailman/listinfo/qftest-list</a><br>
<br></blockquote></div><br>