Mailingliste - Einträge 2006


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [qftestJUI] Command line arguments qfTest - help


  • Subject: Re: [qftestJUI] Command line arguments qfTest - help
  • From: Gregor Schmid <Gregor.Schmid@?.de>
  • Date: 20 Oct 2006 08:54:32 +0200

Hello Marko,

that sounds like a deadlock. Most likely some GUI relevant code in
your application is not executed on the Event Dispatch Thread.

To find out, please trigger a thread dump using the "Create thread
dump" menu item below QF-Test's "Clients" menu, then press Ctrl-T to
the SUT specific terminal, save its contents and send them to us.

Best regards,
    Greg

"Marko Trebovsek" <Marko.Trebovsek@?.com> writes:

> Thank you Gregor, for quick response
> 
> I did as you wrote, but my appl wouldn't start... I mean it starts, but
> is stops loading on e.g 50% and stays there. 
> 
> Than I also modified the settings:
> - class name: com.hp.startup.Bootstrap
> - parameter table for the class:
> com.hp.ov.cadm.wpf.ovstartframe.OVStartFrame
> 	user_settings.xml
> 
> No success... as if my appl is waiting for something?
> 
> Than again i tried to run appl in command line, and it starts fine.
> 
> I am desperate! Is there maybe some other settings I forgot to set?
> 
> 
> Thanks in advance!
> Best regards,
> Marko
> 
> 
> 
> -----Original Message-----
> From: Gregor Schmid [mailto:Gregor.Schmid@?.de] 
> Sent: Thursday, October 19, 2006 4:00 PM
> To: qftestJUI-list@?.de
> Cc: Marko Trebovsek
> Subject: Re: [qftestJUI] Command line arguments qfTest - help
> 
> 
> Hello Marko,
> 
> to start your application directly with its Java command instead of
> through a script or batch file, make sure you use a "Start Java SUT"
> client node and set everything as you described, except:
> 
> - set the "Class name" attribute to com.hp.startup.Bootstrap
> 
> - remove the user_settings.xml from the Parameters table for the
>   executable and put it into the Parameters table for the class.
> 
> Best regards,
>     Greg
> 
> "Marko Trebovsek" <Marko.Trebovsek@?.com> writes:
> 
> >    Helou!
> > 
> > 
> >    I have a problem regarding command line argument:
> > 
> >    I'm trying to start the application in QFTestJUI. Normaly the
> >    application is started in command line with command:
> > 
> >    java
> -DStatusCalculationTutorial=repo\locales\1033\serviceEditor.chm
> >    -cp lib\classloader.jar com.hp.startup.Bootstrap
> >    com.hp.ov.cadm.wpf.ovstartframe.OVStartFrame user_settings.xml
> > 
> > 
> >    I have set parameters as follows:
> > 
> > 
> >    Dir: C:/Program Files/Hewlett-Packard/OpenView/service
> configuration
> >    client/    in this dir the abowe command is working fine
> > 
> >    Class name: com.hp.ov.cadm.wpf.ovstartframe.OVStartFrame
> > 
> >    Executable parameters:
> > 
> >    -
> >    -DStatusCalculationTutorial=repo\locales\1033\serviceEditor.chm
> > 
> >    -          -cp
> > 
> >    -          lib\classloader.jar
> > 
> >    -          com.hp.startup.Bootstrap
> > 
> >    -          user_settings.xml
> > 
> > 
> >    As I try to run this configuration, exception is thrown in
> terminal:
> > 
> >    Exception during startup processing
> > 
> >    java.lang.ClassNotFoundException: user_settings.xml.
> > 
> > 
> >    So if figured it out, that the problem is in user_settings
> parameter.
> > 
> >    What should I do, how should I set this parameter ?
> > 
> > 
> >    Thanks in advance!

-- 
Gregor Schmid                                Gregor.Schmid@?.de
Quality First Software GmbH                     http://www.qfs.de
Tulpenstr. 41                                Tel: +49 8171 919870
DE-82538 Geretsried                          Fax: +49 8171 919876


Videos Downloads Dokumentation Kaufen Gratis Testen