Mailingliste - Einträge 2005


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [qftestJUI] test suite failed and succeded again for no reason


  • Subject: Re: [qftestJUI] test suite failed and succeded again for no reason
  • From: Karlheinz Kellerer <Karlheinz.Kellerer@?.de>
  • Date: Fri, 11 Nov 2005 15:07:03 -0000

Hello Huawei,

Huawei Luo <hluo@?.com> writes:

> Just had a quite strange problem. One of my test suite failed due to a
> "component can't be found" error while the component did actually appeared, I
> checked everything and could not located the reason of the error.  And this
> morning, I run the test suite that failed yesterday, without making any
> changes, and it succeded. Has any one any idea about the possible reasons so
> that next time I won't waste too much time on finding why the component can't
> be found?

There are various reasons (like too restrictive timeouts, changing window titles
...) why a "Component not found" error may occur. If the error doesn't exist anymore
the next day, this _may_ be an idicator that you test needs to be adapted to be
more tolerant. Therefore every "Component not found" error is worth beeing
examined carefully by looking at the run-log, which also can be saved to
preserve the information ;-)

Best regards,
    Karl


--
Karlheinz Kellerer                     Karlheinz.Kellerer@?.de
Quality First Software GmbH                    http://www.qfs.de
Tulpenstr. 41                               Tel: +49 8171 919877
DE-82538 Geretsried                         Fax: +49 8171 919876


Videos Downloads Dokumentation Kaufen Gratis Testen