2018 up to now | 2017 | 2016 | 2015 | 2014 | 2013 | 2012

Mailing List - Entries from 2018 up to now

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
<META NAME="Generator" CONTENT="MS Exchange Server version 6.5.7654.12">
<TITLE>Tests cannot run unattendedly on RedHat 5 </TITLE>
</HEAD>
<BODY>
<!-- Converted from text/rtf format -->

<P><FONT SIZE=2 FACE="Arial">Hi,</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">I am trying to run with qftest some tests on linux. I am using Jenkins and some ant, and the SUT is eclipse. If I connect to vncserver and start the tests manually , I see eclipse starting. </FONT></P>

<P><FONT SIZE=2 FACE="Arial">Yet, in the unattended run they fail with:</FONT>
</P>

<P><FONT FACE="Times New Roman">Client 'WEP-Designer' did not connect for engine 'swt'. Depending on the type of engine you may want to check: - Your JDK instrumentation (for AWT/Swing) - Your SWT instrumentation - Your Start browser node</FONT></P>
<BR>

<P><FONT SIZE=2 FACE="Arial">Further, before I do the invoke ant to start the tests, I do:</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">Vncserver -kill :1</FONT>

<BR><FONT SIZE=2 FACE="Arial">Vncserver :1</FONT>

<BR><FONT SIZE=2 FACE="Arial">Export DISPLAY=vmbam10:1</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">It also says that there is no AWT robot available. I think that XTEST is not installed there.</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">See here the log:</FONT>
</P>

<P><FONT FACE="Times New Roman">[EDATools] $ ant -file preQFT.xml -Dclient=WEP-Designer -Dqft.properties.file=${WORKSPACE}/QFT/ui/shared/TestsExecutionDefault.properties -DsuiteExecution=1 -Dqft.properties.file.resolved=${WORKSPACE}/QFT/ui/shared/ResolvedTestsExecutionDefault.properties -Dinstall.dir=/opt/SoftwareAG -Dqft.tests.home=${WORKSPACE}/QFT -Dinstalldir=/opt/SoftwareAG load.qft.properties Buildfile: /home/vmtest/jenkins/workspace/eda-bvt-test-unix/EDATools/preQFT.xml load.qft.properties: [echo] QFT properties file is: /home/vmtest/jenkins/workspace/eda-bvt-test-unix/QFT/ui/shared/TestsExecutionDefault.properties [echo] QFT resolved properties is: /home/vmtest/jenkins/workspace/eda-bvt-test-unix/QFT/ui/shared/ResolvedTestsExecutionDefault.properties BUILD SUCCESSFUL Total time: 1 second [eda-bvt-test-unix] $ /bin/sh -xe /tmp/hudson8668704011691484762.sh + vncserver -kill :1 Killing Xvnc process ID 7281 + vncserver :1 New 'vmbam10:1 (root)' desktop is vmbam10:1 Starting applications specified in /root/.vnc/xstartup Log file is /root/.vnc/vmbam10:1.log + export DISPLAY=vmbam10:1 + DISPLAY=vmbam10:1 [qftest] $ ant -file build.xml -Dqftest.executable=qftest -Dlogdir=${WORKSPACE}/QFT/output/dtdToXsd -Dreportdir=${WORKSPACE}/QFT/output/dtdToXsd "-Dqftest.arguments=-report.junit ${WORKSPACE}/QFT/output/dtdToXsd -batch -runlog ${WORKSPACE}/QFT/output/dtdToXsd/qftrunlog.xml -report ${WORKSPACE}/QFT/output/dtdToXsd" "-Dsuite=${WORKSPACE}/QFT/ui/shared/qft/startEclipse.qft ${WORKSPACE}/QFT/ui/designer/dtdToXsd/dtd_createFromDtd.qft ${WORKSPACE}/QFT/ui/designer/dtdToXsd/dtd_createFromDtd_rejected.qft ${WORKSPACE}/QFT/ui/shared/qft/stopEclipse.qft" -Dtask.home=${WORKSPACE}/CISTools -Dqftest.dir=/opt/qftest/qftest-3.4M2/bin run.testsuite.Unix Buildfile: /home/vmtest/jenkins/workspace/eda-bvt-test-unix/CISTools/ant_targets/qftest/build.xml set.os.type: run.testsuite.Unix: [exec] 1 (11:56:52.497) PoolThread-0 de.qfs.apps.qftest.shared.extensions.image.AWTImageHandler.updateRobot(): No AWT Robot available - Creating screenshots won't work [exec] 1 (11:56:57.516) PoolThread-1 de.qfs.apps.qftest.shared.extensions.image.AWTImageHandler.updateRobot(): No AWT Robot available - Creating screenshots won't work [exec] 1 (11:57:01.187) PoolThread-2 de.qfs.apps.qftest.shared.extensions.image.AWTImageHandler.updateRobot(): No AWT Robot available - Creating screenshots won't work [exec] 1 (11:57:01.378) PoolThread-0 de.qfs.apps.qftest.shared.extensions.image.AWTImageHandler.updateRobot(): No AWT Robot available - Creating screenshots won't work [exec] 1 (11:57:05.048) PoolThread-1 de.qfs.apps.qftest.shared.extensions.image.AWTImageHandler.updateRobot(): No AWT Robot available - Creating screenshots won't work [exec] 1 (11:57:05.233) PoolThread-2 de.qfs.apps.qftest.shared.extensions.image.AWTImageHandler.updateRobot(): No AWT Robot available - Creating screenshots won't work [exec] Result: 3 BUILD SUCCESSFUL Total time: 10 minutes 42 seconds Total time: 10 mi[EDATools] $ ant -file install.eclipse.plugin.xml -Dcis.tools.home=${WORKSPACE}/CISTools -Dplugin.name=connectors -Dqft.tests.home=${WORKSPACE}/QFT -Dinstalldir=/opt/SoftwareAG delete.plugin Buildfile: /home/vmtest/jenkins/workspace/eda-bvt-test-unix/EDATools/install.eclipse.plugin.xml </FONT></P>
<BR>

<P><FONT FACE="Times New Roman">I hope you can help me,</FONT>
</P>

<P><FONT FACE="Times New Roman">Best regards,<BR>
</FONT>

<BR><FONT FACE="Times New Roman">Ledda</FONT>
</P>

</BODY>
</HTML>