2018 up to now | 2017 | 2016 | 2015 | 2014 | 2013 | 2012

Mailing List - Entries from 2018 up to now

<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 12 (filtered medium)">
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page Section1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.Section1
        {page:Section1;}
-->
</style><!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="blue" vlink="purple">
<div class="Section1">
<p class="MsoNormal">Hello QFTest users/developers,<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">I posted a while back about having trouble getting QFTest to run in our CI system (Zutubi Pulse).  I’ve had some success getting this to work now, and we’re running nightly builds now (sort of), but there’s a complication which prevents
 this from being really useful: a user with access to the desktop has to be logged in at the time of the build, and a *<b>real</b>* desktop has to be active (i.e. if you log out, or the session becomes inactive, the tests start failing).  This user account
 must be the same as that which the build agent service runs under (this is all on Windows, if that wasn’t obvious).   I wondered if this was just some peculiarity to the way Zutubi Pulse handles things, and so I tried running with Hudson as well (similar setup,
 build agent runs as service under a particular user account) and found the exact same results.  If the build agent user is not really, really logged in, with a real desktop session going, you get a lot of ComponentNotFoundExceptions, etc.  If you look at the
 run-log, the screenshots for the failures show something like the outline of the application window, and everything that’s supposed to be inside it looks blank (see attached run-log).<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Obviously, having to manually log in to start a test makes things awfully inconvenient for nightly builds :)
<o:p></o:p></p>
<p class="MsoNormal">Has anyone encountered something similar to this?  Any ideas why it’s happening or how to fix/workaround?<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Thanks,<o:p></o:p></p>
<p class="MsoNormal">Troy Nichols <o:p></o:p></p>
</div>
<br>
<hr>
<font face="Arial" color="Gray" size="1">This e-mail transmission may contain information that is proprietary, privileged and/or confidential and is intended exclusively for the person(s) to whom it is addressed. Any use, copying, retention or disclosure by
 any person other than the intended recipient or the intended recipient's designees is strictly prohibited. If you are the intended recipient, you must treat the information in confidence and in accordance with all laws related to the privacy and confidentiality
 of such information. If you are not the intended recipient or their designee, please notify the sender immediately by return e-mail and delete all copies of this email, including all attachments.<br>
<br>
Intervoice, Inc. 17811 Waterview Parkway Dallas, TX 75252 USA<br>
<br>
Intervoice Limited, Registered in England and Wales with number 2601740, 50 Park Road, Gatley, Cheshire, SK8 4HZ. VAT Number: 560421375<br>
<br>
Intervoice GmbH, Hagenauer Straße 55, 65203 Wiesbaden, Sitz der Gesellschaft: Wiesbaden, Handelsregister: HRB 8186 (Amtsgericht Wiesbaden), Geschäftsführer: Wayne Barclay, Steffen Selbmann<br>
</font>
</body>
</html>