List Icon
Mailing list Archive

2019 up to July 2022 | 20182017  |  2016  2015 2014 | 2013

The mailing list has been closed since July 2022, but continues to serve as an archive of information about QF-Test.
But if you want to stay informed about news about QF-Test, you can simply
Subscribe to Newsletter  

To get up-to-date information about each release - including minor releases - you can
subscribe to the RSS feed or follow us on social media.
Alternatively, QF-Test also provides release information itself.

Another source of information is our blog, where there are current articles on general topics, on the company QFS and also various "how-tos"
subscribe to blog


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [QF-Test] how to suppress New Java security warning message


  • Subject: Re: [QF-Test] how to suppress New Java security warning message
  • From: Gregor Schmid <Gregor.Schmid@?.de>
  • Date: Mon, 28 Apr 2014 07:50:27 +0200

Hi Sweatha,

Oracle have been tightening security for Java WebStart over the past
1-2 years, introducing new dialogs, options and requirements with
every new Java version.

QF-Test has been keeping up and it will automatically confirm and
close security dialogs for you during startup (at least those that can
be closed) but you need to use a current version of QF-Test.

For WebStart your best option is to switch to QF-Test 4. The beta
status of this version mostly applies to the new features, i.e. JavaFX
and Chrome support. The new mechanism for connecting with the SUT,
base on the Java agent mechanism, is vastly superior especially for
Java WebStart and your company is entitled to a free upgrade.

Alternatively you can use QF-Test 3.5.5 (or 3.5.6 which is going to be
released this week). If you run into any problems with Java WebStart
and a current QF-Test version, please send a run-log of the startup
sequence to our support and we'll take it from there.

Best regards,
    Greg

"Kasiviswanathan, Sweatha" <sweatha.kasiviswanathan@?.com> writes:

> Hi,
>
>   In the recent versions of java 7 update 50+ we have a new security warning that says:
>
> Do you want to run this application
>
> How do we suppress this warning from qftest?
>
> This warning happens before Wait for client to Connect and after Start SUT client. In between
> these two.
>
> We need to suppress this warning along with Start SUT client code. How can we achieve that?
>
> Thanks,
>
> Sweatha.

--
Gregor Schmid

E: gregor.schmid@?.de
T: +49 (0)8171 38648-11
F: +49 (0)8171 38648-16

Quality First Software GmbH | www.qfs.de
Tulpenstr. 41 | 82538 Geretsried | Germany
GF Gregor Schmid, Karlheinz Kellerer
HRB München 140833