2018 up to now | 2017 | 2016 | 2015 | 2014 | 2013 | 2012

Mailing List - Entries of 2012


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [QF-Test] qft java integration


  • Subject: Re: [QF-Test] qft java integration
  • From: "Berg, Klaus-Peter" <klaus-peter.berg@?.com>
  • Date: Tue, 31 Jan 2012 14:29:25 +0100

Hi Nimrod,
 
if it compiles but throws a *Runtime* error, you should check if you are using the same qflib/*.jars in your Eclipse classpath that are part of your current QF-Test 3.4.2 installation.
Perhaps you copied the /qflib/*.jars to a lib directory of your Eclipse project sometime ago and in the meantime you have upgraded to a newer QF-Test version and you forgot to copy the files again? The file in question is especially 'qftest.jar' but other qflib/*.jar files would be affected as well...
 
Or are you using these QF-Test jar files as Eclipse project "external JAR files"?
 
Regards,
Klaus Peter


From: qftest-list-bounces@?.de [mailto:qftest-list-bounces@?.de] On Behalf Of nimrod cohen
Sent: Dienstag, 31. Januar 2012 09:37
To: qftest-list@?.de
Subject: [QF-Test] qft java integration


Hi

I’m trying to integrate java and qft using Daemon Api

The compellation is ok but on run time it fail l on unclear problem

My code

import de.qfs.apps.qftest.daemon.DaemonLocator;

import de.qfs.apps.qftest.daemon.Daemon;

Daemon daemon = DaemonLocator.instance().locateDaemon(Host, port);

the error is : “could not resolve type : de.qfs.apps.qftest.daemon.DaemonLocator”

The class exist and it’s on my classpath.

Qft version : 3.4.2

The Daemon is up

My java is : 1.6.0_13

Ide : eclipse

Any idea ? 


nimco