Mailing list - Entries of 2005


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [qftestJUI] Wrong Client attribute when recording


  • Subject: Re: [qftestJUI] Wrong Client attribute when recording
  • From: Gregor Schmid <Gregor.Schmid@?.de>
  • Date: 17 Dec 2005 11:54:34 +0100

Hello Bastian,

that qftestJUI records $(id) instead of the plain client name is an
important feature because normally $(id) is what you want. It makes it
possible to drive multiple SUT clients with different client names if
needed. As long as you're using only one client you just have to make
sure that id is defined. By the way, we suggest to use $(client)
instead of $(id), but that's irrelevant.

If you really want the client name recorded instead of the variable,
put the plain client name in the SUT start node or disable the option
"Record->Keep variables in recorded client names".

Best regards,
    Greg

Bastian Bowe <Bastian.Bowe@?.de> writes:

> Hello,
>
> I'm starting my SUT using a shell command node. The "Client" attribute of
> this node is set using a variable. Recording events however records the
> events using the variable name ("$(id)") as the Client attribute of the
> recorded nodes instead of the variable's value.
> In the runlog I can see that the Client attribute variable IS evaluated so
> that the value of the variable is beeing used as the client id. Playback
> works without any issues.
>
> Any ideas?
>
> Regards
>
> Bastian
> _______________________________________________
> qftestJUI-list mailing list
> qftestJUI-list@?.de
> http://www.qfs.de/mailman/listinfo/qftestjui-list

--
Gregor Schmid                                Gregor.Schmid@?.de
Quality First Software GmbH                     http://www.qfs.de
Tulpenstr. 41                                Tel: +49 8171 919870
DE-82538 Geretsried                          Fax: +49 8171 919876


Videos Downloads Documentation Buy Free Trial