Mailing list - Entries of 2005


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[qftestJUI] wait for exit in batch mode


  • Subject: [qftestJUI] wait for exit in batch mode
  • From: Bastian Bowe <Bastian.Bowe@?.de>
  • Date: Wed, 21 Sep 2005 15:00:57 +0200

Hello,

my testrun interrupts with ClientNotTerminatedException when run in batch
mode. Doing the same run from gui mode doesn't make trouble. The client
started is not the real SUT. It is a small nogui java tool for setting a
defined database setup. I've put together a Java SUT Client node followed
by a "wait for exit" node. This works fine in gui mode but not in batch
mode.

On the Console (stderr) I get
1 (14:45:15.640) main de.qfs.apps.qftest.start.TestRunner.start(String[]):
java.lang.NullPointerException: null
2 (14:45:15.640) main de.qfs.apps.qftest.start.TestRunner.start(String[]):
java.lang.NullPointerException
        at java.io.File.<init>(Unknown Source)
        at de.qfs.apps.qftest.log.Transform.transform(Transform.java:189)
        at
de.qfs.apps.qftest.start.TestRunner.convertLog(TestRunner.java:848)
        at
de.qfs.apps.qftest.start.TestRunnerImpl.runTests(TestRunnerImpl.java:218)
        at
de.qfs.apps.qftest.start.TestRunner.runTests(TestRunner.java:581)
        at de.qfs.apps.qftest.start.TestRunner.start(TestRunner.java:250)
        at de.qfs.apps.qftest.start.TestRunner.main(TestRunner.java:129)

in qfconnect.log:
6654: --------------------------------------------------------------------
6654: Started: Wed Sep 21 14:45:01 CEST 2005
6654: Connector version: 9
6654: java.lang.Exception: Stack Dump
        at
de.qfs.apps.qftest.start.Connector.maybeConnect(Connector.java:180)
        at de.qfs.apps.qftest.start.Connector.access$0(Connector.java)
        at de.qfs.apps.qftest.start.Connector$1.run(Connector.java:129)
        at java.security.AccessController.doPrivileged(Native Method)
        at de.qfs.apps.qftest.start.Connector.<init>(Connector.java:126)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
        at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
        at java.lang.Class.newInstance0(Class.java:308)
        at java.lang.Class.newInstance(Class.java:261)
        at java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:688)
        at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:774)
        at de.qfs.lib.gui.EventQueue.install(EventQueue.java:254)
        at
de.qfs.apps.qftest.client.TestEventQueue.install(TestEventQueue.java:233)
        at
de.qfs.apps.qftest.start.StartClient.setupEventQueue(StartClient.java:453)
        at
de.qfs.apps.qftest.start.StartClient.start(StartClient.java:310)
        at de.qfs.apps.qftest.start.StartClient.main(StartClient.java:189)
6654: System properties: ...
6654: conector suppressed

What am I doing wrong? Or is this a qftest bug?

Kind Regards

Bastian


Videos Downloads Documentation Buy Free Trial